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2 Understanding WebAnimator

Before you dive into WebAnimator, it is recommended that you read this chapter 
to become familiar with the features of WebAnimator. This chapter provides you 
with an introduction to the functions, tools, and features of WebAnimator. 

This chapter covers:

• Starting WebAnimator

• Understanding how scenes are created

• Understanding how keyframes are used in WebAnimator

• Understanding the six different views in WebAnimator

• Working with original images

• Playing your scenes

Introducing WebAnimator
WebAnimator is a set of tools that lets you quickly and easily create and deliver 
multimedia over the Internet's World Wide Web. It consists of two parts. The first 
is an authoring tool that lets you create and import graphics, animate objects, adjust 
timing, and synchronize sounds to create full-fledged multimedia “scenes.” The 
second part is a plug-in player for Netscape Plug-in-compatible Web browsers 
(such as Netscape Navigator and Microsoft Internet Explorer).

What can you create with WebAnimator? Your options are virtually unlimited. 
Multimedia development offers exceptional flexibility, allowing you to present 
information in a variety of ways through graphics, sound, motion, and interaction. 
Following are some examples of things you might create with WebAnimator:

• An animated, interactive home page banner with buttons that branch to 
all the sections in your Web site.

• Interactive over-the-Web presentations.

• Spinning bullet items for lists.

• Interactive navigational buttons for your Web site.

• Training and educational materials.
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WebAnimator has many powerful features that allow you to create exciting 
multimedia scenes for your Web site.

Multimedia templates
Templates provided with WebAnimator are professionally designed multimedia 
animations. You can customize these pre-made animations for your own Web 
pages.

Templates contain all the animation, buttons, graphics, and sound effects you need 
to make an animated Web page. All you need to do is enter your own text, which 
will be substituted for the animated text in the template. You can then script the 
buttons in the template to branch to different Web pages when they are selected. 
You can add your own speech to welcome visitors to your Web page or to give 
them instructions, or add background music to set a mood. Other animated objects 
such as spinning logos can also be added to the page.

Graphics and animation
WebAnimator lets you draw and import graphics, and makes it easy to apply 
animation effects like sliding objects, sweeps, growing and shrinking objects, 
transitions, and much more. You create animated scenes by making keyframes for 
each state of your scene. WebAnimator automatically generates the animation that 
takes your scene from one keyframe to the next.

Sound
Sound is a critical part of multimedia production. WebAnimator comes with 
professionally-designed music and sound effect clips to bring life to your 
animation. After creating animation effects, you will be pleasantly surprised at 
what a difference the right sound makes. WebAnimator gives you all the tools you 
need to import sounds and record your own voice. Then, you can synchronize and 
loop sounds to fit the animation you create by using simple menu commands.

Interaction
WebAnimator’s interaction tools let you script your scene to create buttons that 
depress and behave in much the same fashion as the buttons you see in your 
software applications. Powerful scripting tools let you create “roll-over” effects and 
control repetition, looping, and more. The result is a multimedia experience that 
gives your users feedback to mouse action and an excellent “feel” for your scenes.

Integration with popular Web browsers
Visitors to your Web site can view your scenes with the freely-distributed plug-in 
player. The player works with any Netscape Plug-in-compatible browsers, 
including Netscape Navigator and Microsoft Internet Explorer. Users can 
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download the small plug-in player from DeltaPoint’s Web site at 
http://www.deltapoint.com. You can freely pass the plug-in player on to 
your clients and users.

Small file sizes
One of the drawbacks of multimedia has traditionally been the large amounts of 
memory and disk space that productions require. WebAnimator avoids much of this 
problem in two ways. First, all objects drawn in WebAnimator are vector-based, 
instead of being bitmaps. Vector images are much smaller than bitmap images. 
Second, WebAnimator provides powerful sound and graphics compression. The 
judicious use of imported graphics and sounds, along with these two factors, results 
in very small scene files that are practical for download even by modem users.

Ease of use
Possibly the best thing about WebAnimator is that it gives you all of this 
functionality without requiring programming or animation expertise. Simple mouse 
clicks, drags, and menu commands are all it takes to create exciting multimedia 
scenes. In fact, if you can type text, then you can take advantage of WebAnimator’s 
library of professionally-designed multimedia templates.

What you need to know to use WebAnimator
Using WebAnimator to create multimedia scenes requires no knowledge of 
programming, Web authoring, Web site publishing, or Web server technology. 
However, in order to place your WebAnimator scenes in Web pages, you need to 
know how to edit HTML files. 

WebAnimator is not an HTML authoring tool or Web site publishing tool. 
WebAnimator simply allows you to create multimedia content which can be placed 
in Web pages. If you are interested in software to help you create Web pages and 
manage your Web site, contact DeltaPoint for information on DeltaPoint QuickSite.

For the sake of brevity, this manual focuses primarily on the creation of multimedia 
scenes using the WebAnimator authoring tool. With respect to publishing Web 
sites, this manual assumes that you are familiar with the general terminology of the 
Internet and the World Wide Web. It also assumes that you have the resources and 
knowledge you need to create HTML pages and publish them on the World Wide 
Web.

There are many excellent sources to gain knowledge of these subjects, most of 
which can be found on the Internet and at your local bookseller.
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You can create a Web page with DeltaPoint QuickSite or Adobe PageMill™ with a 
space for animation without using/editing the HTML file.

Starting WebAnimator
The initial view that is displayed when WebAnimator is started, depends on the 
startup view you selected in the General preferences dialog (choose “Preferences” 
from the Edit menu and select “General...” from the cascading menu). 

To start WebAnimator (Macintosh):
1. Locate the DeltaPoint WebAnimator™ icon in the WebAnimator folder.

2. Double-click the icon or select the icon and choose “Open” from the Finder File 
menu.

By default, WebAnimator starts up in the Animation view as shown in 
Figure 2-7 on page 2-22. 

To start WebAnimator (Windows 95):
1. Click on the Start menu, then point to “Programs,” then “DeltaPoint 

WebAnimator,” then click on “DeltaPoint WebAnimator.”

By default, WebAnimator starts up in the Animation view as shown in 
Figure 2-7 on page 2-22. 

Terminology
In order to use WebAnimator, you need to understand a few terms and concepts 
concerning animations. Additional sections at the end of this chapter discuss more 
detailed concepts that require more understanding of WebAnimator.

Scenes and keyframes 
A WebAnimator scene is similar to a movie, as it is composed of a sequence of 
frames. Also, as in a movie, each WebAnimator frame consists of pictures and 
sounds. Scenes can contain animation, graphics, sounds, and can be interactive. 
You can draw or import the graphics into your scenes. You can also create 
animated objects and import and synchronize sounds.

Each frame of a WebAnimator scene lasts 1/30 of a second. Since it is tedious to 
create frame after frame manually, WebAnimator automates the process: You 
design keyframes and WebAnimator generates the animation frames automatically.
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WebAnimator’s keyframe approach makes it easy to design and edit a scene. For 
example, you might want to have the word “Amazing” move across the screen. To 
do this, you would create two keyframes. In the first keyframe you would show 
where the movement was to start; in the second, where the movement was to end.

WebAnimator automatically generates the animation frames in between the “start” 
and “end” keyframes to make the movement smooth. You can create as many 
keyframes as you like to produce exciting interactive multimedia scenes.

Figure 2-1. Keyframes and animation frames

With WebAnimator’s keyframe approach, it is easy to change the length of time of 
an animation. You may tell WebAnimator how long you want each sequence to 
run. WebAnimator generates the exact number of frames needed to fill the time you 
have specified. 

Understanding viewing planes
Each keyframe consists of three viewing planes—foreground, background, and 
hidden. These viewing planes allow you to hide objects which should be invisible 
in selected keyframes, and speed animation by consigning unmoving background 
elements to a background viewing plane. Imagine each object drawn upon a clear 
celluloid film. The viewing plane is the order in which the films are stacked. 

Keyframe

Animation frames

Start

End Keyframe
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Figure 2-2. WebAnimator viewing planes

The foreground viewing plane is where movement of objects takes place. 
Unmoving objects which appear behind the moving objects can be placed in the 
background viewing plane. Objects which appear later on in your scene can be 
hidden on the hidden viewing plane and brought to the foreground as needed. When 
the scene is played, the viewer sees the foreground/background combination. 
Remember that objects occupy a place in the viewing plane whether or not they 
visibly overlap.

The viewing plane controls in the Animation and Storyboard view tool palettes 
allow you to display selected planes or, when used in combination with the Cmd 
key on the Macintosh or the Ctrl key in Windows, move an object from one plane 
to another. The default setting for this control is the foreground/background 
combination, which is what is displayed when the scene is played.

The “Viewing Plane” command under the Views menu can also be used to display 
the various viewing planes for review.

To learn more about refer to

Using the viewing planes “Using viewing planes,” on page 5-6
Layering objects within a viewing plane “Layering objects,” on page 5-38

Foreground

Background

Hidden
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Features of the WebAnimator views
Each view contains a tool palette which contains tools and buttons specifically for 
the tasks which can be done in that view. Some of the tools and buttons are the 
same in each view, for example the New button. The function of the New button is 
different in the Draw view than in the Storyboard or Template Studio view.

WebAnimator views
Even though you can do many of the same tasks in different views, as you work in 
WebAnimator you will develop your own system for accomplishing tasks in the 
views.

Template Studio view Allows you to create scenes with the use of prerecorded 
animated Scene Templates.

Animation view Displays one keyframe at a time in actual size. Allows you to 
customize the animation of your scene by moving objects within keyframes, 
importing graphics and animation, and resizing objects.

Storyboard view Displays all of the keyframes in the current scene in storyboard 
fashion. Allows you to view your scene keyframe by keyframe to edit and adjust 
your scene as you go along. You can also add sound or change more than one 
keyframe at a time. Changes can be made to multiple keyframes by selecting them 
with the Shift key or dragging a selection box around the keyframes.

Draw view Displays one keyframes or one cel at a time in actual size. Allows you 
to draw shapes and add text objects in selected keyframes, create Sprite objects, and 
apply colors and shadows.

Cel view Displays all of the cels of the current Sprite in a storyboard fashion. 
Allows you to create and import separate animated objects not controlled by the 
scene keyframes.

Project view Allows you to combine multiple scenes into a single multimedia 
scene. If you are creating animated scenes for your Web site, it is recommended 
that you do not combine your scenes in the Project view.
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Working in the Template Studio view
The main purpose of the Template Studio view is to create scenes by opening and 
using animated Scene Templates included with WebAnimator. Scene Templates 
contain all the animation, buttons, graphics, and sound effects you need to make an 
animated Web page. The templates can then be customized by entering text, adding 
sound, changing backgrounds, importing graphics, animated logos, links to branch 
to different Web pages, etc.

Existing WebAnimator Template Libraries can be opened using the Open Library 
button in the Template Studio command palette or the “Change Library...” 
command in the Template menu. You can create your own templates and libraries 
in the Animation view. These views are discussed later on in this User’s Guide.

Templates provided with WebAnimator are professionally designed multimedia 
animations. You can customize these pre-made animations for your own Web 
pages.

These templates have all been created in WebAnimator’s Storyboard view. When 
you use a template, it creates a new Storyboard which you can edit. And for those 
who are ambitious, they can use WebAnimator’s Storyboard view to create new 
templates for their own or others use.

To learn more about refer to

Creating or using scene templates Chapter 4, “Using and Creating Scene 
Templates”

Template Studio view main features
The Template Studio view looks completely different from other WebAnimator 
views. Most of the functionality is designed specifically for using Scene Templates. 
Most of the menu options and buttons in this view are not present in other 
WebAnimator views.

The Template Studio can be displayed by using the “Template Studio” command 
from the View menu, or clicking on the Template Studio button from the 
WebAnimator View Bar. You are prompted to select a Template Library before 
continuing. Once a library has been opened, WebAnimator automatically opens to 
the Template Studio view. You can change the default view in the General 
preferences dialog.
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Figure 2-3. Template Studio view
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Table 2-1. The Template Studio main features

Feature Function

Action Lets you specify a branch script message to send when the 
corresponding button or text is clicked. This can be used 
to branch to a different keyframe in the scene or a URL 
address (i.e., htp://www.deltapoint.com).

Command palette Consists of icon buttons which represent various functions 
and commands available in the Template Studio.

Elapsed Time Indicator Indicates the time used to display the selected line of text. 
This time can be changed by simply clicking in the Time 
column adjacent to the text.

Viewing Plane Determines whether graphics imported into a keyframe go 
into the foreground or background of a keyframe. Works 
in conjunction with the Import commands.

Pause Pauses the animation at the corresponding text until the 
mouse button is clicked by the viewer.

Play (Macintosh only) Plays the current scene. To stop the 
scene, press z-period. To continue working in the 
Template Studio, switch back to it by clicking its icon in 
the View Bar.

Scene Preview Displays the current scene. Objects that have been 
imported or drawn into a keyframe can be re-positioned 
by dragging them within this view frame.

Sound Segments Displays a dialog so you can record a sound to accompany 
the corresponding line of text.

Text Entry Lines Allows you to enter text to place in the selected template. 
Only the lines available for the selected template are 
active.

View Bar Allows you to switch between the Template Studio, 
Animation, Storyboard, Draw, Cel, and Project views.
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Template Studio command palette
This command palette is contained in the Template Studio view. A majority of the 
commands available in the Template Studio view can be accessed using the buttons 
in the command palette. 

Figure 2-4. Template Studio command palette

Table 2-2. Template Studio command palette functions

Button Function

Templates... displays a dialog so you can choose one of the templates 
from the currently open Scene Template Library. You can load one 
template per scene.

This function can also be performed by choosing “Select 
Template...” from the Template menu.

Background... displays a dialog so you can change or apply color to 
the background. You can also apply blends to the background using 
this command.

Music/Sound... displays a dialog so you can select a sound file which 
plays repeatedly for this scene. 

This function can also be performed by choosing “Background 
Music...” from the Template menu.

MacintoshWindows
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Library... displays a dialog so you can change the currently open 
Scene Template Library. A library consists of prerecorded and 
designed animation scenes. These may consist of sound, animation, 
and transitions. 

This function can also be performed by choosing “Change 
Library...” from the Template menu.

Draw View displays the Draw view where you can draw objects and 
text to add to the current scene. When finished drawing, return to the 
Template Studio view by clicking the Template Studio button in the 
View Bar or selecting “Template Studio” from the View menu. 

This function can also be performed by choosing “Draw” from the 
View menu, or by pressing Cmd/Ctrl-D.

Smooth smooths the selected keyframes based on the smooth 
preferences previously selected. Smoothing pre-generates 
animation frames and saves them in the scene file.

This function is not recommended for Web use. Smoothed scenes 
require substantially more memory and hard disk space than 
unsmoothed scenes.

This function can also be performed by choosing “Smooth” from the 
Template menu.

Import Graphic... displays a dialog so you can import art files into the 
scene. 

This function can also be performed by choosing “Import” from the 
File menu and selecting “Graphics...” from the cascading menu.

Import Animation... displays a dialog so you can import animated 
PICS files and WebAnimator objects into the current scene.

This function can also be performed by choosing “Import” from the 
File menu and selecting “Animated Object (PICS)” from the 
cascading menu.

Table 2-2. Template Studio command palette functions CONTINUED

Button Function
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Working in the Storyboard view
The Storyboard view displays all the keyframes of a scene laid out consecutively in 
rows. You may edit keyframes and the position and size of objects in the 
Storyboard view. You may also change the time or speed your scene takes to play, 
and add sound and interactivity to your scene.

The Storyboard view lets you manage the general aspects of your scene. This 
includes importing and creating sound, moving objects across multiple keyframes, 
and scripting frames. Most of these actions can also be performed in the Animation 
view, but the Storyboard allows you to view and manage the relationships among 
multiple keyframes more easily.

You can animate objects roughly in the Storyboard. For precise movements and 
placement, use the Animation view.

To learn more about refer to

Adding sound “Working with sound in your scene,” on page 7-2
Adjusting timing “Adjusting keyframe timing,” on page 7-13

Save Movie... (Macintosh only) displays a dialog so you can export 
the current scene as a QuickTime movie. 

This function can also be performed by choosing “Export 
QuickTime...” from the File menu.

Play (Windows only) Plays the current scene. To stop the scene, 
press Esc. To continue working in the Template Studio, switch back 
to it by clicking its icon in the View Bar. 

This function can also be performed by choosing “Play” from the 
Play menu.

Table 2-2. Template Studio command palette functions CONTINUED

Button Function
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Storyboard view main features
To open the Storyboard view, choose “Storyboard” from the View menu, press 
Cmd/Ctrl-Y, or click the Storyboard button from the WebAnimator View Bar. As 
you can see from Figure 2-5, you can display different types of information in the 
Storyboard view. The three different modes can be displayed using the tool pallet 
or the “View Info” command from the View menu.

Click Sound within the Storyboard view tool palette to display the sound mode. In 
this mode, any existing sound segments are displayed in the Storyboard view. It is 
possible to create new sound segments, record sounds, place sound files into 
selected segments, listen to sounds, synchronize sounds to keyframes, and stretch 
sound segments across multiple keyframes.

Click Names to display the names mode. In this mode, any names assigned to 
keyframes are displayed. It is possible to change existing names or assign names to 
other keyframes.

Click Time to display the default time mode. In this mode, the default or assigned 
times for each keyframe are displayed. It is possible to change existing times for 
individual keyframes or the total time for the entire scene.
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Figure 2-5. Storyboard view

Table 2-3. The Storyboard main features

Feature Function

Elapsed Keyframe Time Displays the time between this keyframe and the next 
keyframe. You may change the time for a keyframe by 
clicking on its time control, and entering the desired time in 
minutes, seconds and frames.

Click the “Time” button in the tool palette to display the 
keyframe time. Click in the keyframe time display to 
change the time, or select a frame or range of keyframes 
and choose “Change Time...” from the Animation menu.

Keyframe
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Elapsed Scene Time Displays a running total time for the entire scene at each 
keyframe. Elapsed scene time is automatically generated 
based on the total of all elapsed keyframe times. 

Click the “Time” button in the tool palette to display the 
scene time.

Keyframe An increment within a scene. Each keyframe can be 
changed individually for animation, sound, time, and 
transition within the Storyboard view. 

In-between frames are automatically inserted between each 
keyframe to smooth the animation.

Keyframe Name Displays the name you assign to each keyframe. Assigning 
names is helpful for creating scripts, templates, and 
managing your scene.

Click the “Name” button in the tool palette to create, 
modify, and display keyframe names. Click beneath a 
keyframe to insert a name, or select a frame and choose 
“Change Name...” from the Animation menu. Each 
keyframe is automatically assigned an Untitled name.

Selected Keyframe Indicates the selected keyframe(s). Multiple keyframes can 
be selected by holding down the Shift key while clicking on 
additional keyframes in sequence or click-drag to select 
multiple row and columns at a time. You can select a series 
of keyframes by clicking the first and Shift-clicking the 
last.

WebAnimator automatically scrolls when you click and 
drag to select multiple keyframes.

Show Off Screen button Displays all keyframes at 50 percent size centered in the 
window and displays elements that are outside the 
keyframe boundary. These are objects that have been 
selected and moved off the visible portion of the keyframe, 
facilitating the ability to make objects slide in from off 
screen.

Table 2-3. The Storyboard main features CONTINUED

Feature Function
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Storyboard view tool palette
This tool palette appears when you are in the Storyboard view. A majority of the 
commands available in the Storyboard view can be accessed using the buttons in 
the tool palette. 

The Storyboard tool palette “floats” above the screen. It can be moved anywhere on 
the screen. This tool palette is much like the Animation view tool palette, and 
several of the buttons work in a similar fashion. Times, Names and Sound, 
however, are specific to the Storyboard view tool palette.

Play Plays the current scene from the selected keyframe. To stop 
the scene, press Cmd-period for Macintosh or Esc for 
Windows.

Sound Segment Displays any sound segments applied to your scene in the 
current sound track. Sound can be synchronized to the 
animation, the animation can be synchronized to the sound, 
or sound can be applied to the scene without 
synchronization.

Click the “Sound” button in the tool palette to create, 
modify, and display sound segments.

Tool palette Contains controls for creating sound tracks, adjusting the 
timing of the keyframes, playing the current scene, 
adjusting the viewing plane of objects in the current scene, 
creating new objects, selecting, moving, and resizing 
objects, and naming keyframes. (see Figure 2-6)

View Bar Allows you to switch between the Template Studio, 
Animation, Storyboard, Draw, Cel, and Project views.

Table 2-3. The Storyboard main features CONTINUED

Feature Function



2-18 WebAnimator User’s Guide

Features of the WebAnimator views Understanding WebAnimator

Figure 2-6. Storyboard view tool palette

Table 2-4. Storyboard view tool palette functions

Tool/Button Function

The Pointer tool allows you to select, resize, and move objects 
within the Storyboard view. If you select an object in one keyframe, 
the same object is selected when you click on a different keyframe. 
This is helpful if you have moved an object off screen.

Other movement commands are available by choosing “Send 
Object” from the Animation menu.

The Resize tool allows you to resize objects from the center point in 
the Storyboard view. If more than one keyframe is selected when 
you resize an object, that object is resized in all selected keyframes. 
Resizing affects the object only in the selected keyframes.

Other sizing commands are available by choosing “Size Object” 
from the Animation menu or using its handles.

The Play button allows you to play the current scene from the 
selected keyframe. To play the scene from the beginning, click on 
the first frame in the scene. 

This function can also be performed by choosing “Play” from the 
Play menu and selecting one of the play options from the cascading 
menu. To stop the scene, press Cmd-period for Macintosh and Esc 
for Windows.

View 
Time

New Key Frame

Play

Background Viewing Plane

Resize

Hidden Viewing Plane

Pointer

Foreground Viewing Plane

View Names

View Sound
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Time displays the Elapsed Scene and Keyframe times directly below 
each keyframe. Both times can be edited to speed up and slow down 
your animated scene.

This function can also be performed by choosing “Viewing Info” 
from the View menu and selecting “Times” from the cascading 
menu.

Names displays the names of each keyframe directly below each 
keyframe. While in this mode, click anywhere beneath a keyframe 
to enter a name. Names are required for scripting.

This function can also be performed by choosing “Viewing Info” 
from the View menu and selecting “Names” from the cascading 
menu.

Sound displays the sound segments applied to each keyframe 
directly below each keyframe. Sound segments can be applied to 
individual keyframes or across multiple keyframes.

This function can also be performed by choosing “Viewing Info” 
from the View menu and selecting “Sound Tracks” from the 
cascading menu.

New is used to insert a new keyframe directly after the selected 
keyframe. The new keyframe is identical to the selected keyframe.

This function can also be performed by choosing “New Keyframe” 
from the Edit menu, or pressing Cmd/Ctrl-K.

Holding down Cmd/Ctrl while selecting New creates a new 
keyframe with all objects and backgrounds removed. 

Table 2-4. Storyboard view tool palette functions CONTINUED

Tool/Button Function



2-20 WebAnimator User’s Guide

Features of the WebAnimator views Understanding WebAnimator

Fore displays the foreground viewing plane of the keyframe. The 
foreground viewing plane usually contains all of the objects which 
are animated. You can also click on the Back button at the same time 
to display both planes.

This function can also be performed by choosing “Viewing Plane” 
from the View menu and selecting “Foreground” from the cascading 
menu.

You can send a selected object to the foreground by pressing Cmd/
Ctrl while clicking on this button, choosing “Send Object” from the 
Animation menu and selecting “To Foreground” from the cascading 
menu, or pressing Cmd/Ctrl-F.

Back displays the background viewing plane of the keyframe. The 
background viewing plane usually contains all stationary objects 
contained in more than one keyframe. You can also click on the Fore 
button at the same time to display both planes.

This function can also be performed by choosing “Viewing Plane” 
from the View menu and selecting “Background” from the 
cascading menu.

You can send a selected object to the background by pressing Cmd/
Ctrl while clicking on this button, choosing “Send Object” from the 
Animation menu and selecting “To Background” from the 
cascading menu, or pressing Cmd/Ctrl-G.

Hidden button displays the hidden viewing plane of the keyframe. 
The hidden viewing plane usually contains all objects within each 
keyframe that are not displayed in background or foreground planes. 
This command is useful when you have hidden an object and need 
to make it visible in one or more selected keyframes.

This function can also be performed by choosing “Viewing Plane” 
from the View menu and selecting “Hidden” from the cascading 
menu.

You can send a selected object to the hidden plane by pressing 
Cmd/Ctrl while clicking on this button, choosing “Send Object” 
from the Animation menu and selecting “To Hidden” from the 
cascading menu, or pressing Cmd/Ctrl-H.

Table 2-4. Storyboard view tool palette functions CONTINUED

Tool/Button Function
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To learn more about refer to

Simple and Complex objects “Creating simple and complex objects,” on page 5-8

Working in the Animation view
Animation view is a look into the Storyboard view one keyframe at a time. Just 
about all of the functions available in the Storyboard view are available in 
Animation view. The advantage of Animation view is that the keyframe is 
displayed at it’s full size, so it is easier to layout objects.

You can navigate through the Storyboard using the Animation view tool palette. 
You can even select multiple key frames using the select frames button on the 
bottom of the window. Moving objects, entering transitions, recording sounds, and 
creating buttons and scripts all work the same as in Storyboard view.

Animation view main features
To open the Animation view, choose “Animation” from the View menu, press 
Cmd/Ctrl-U, or click the Animation button from the WebAnimator View Bar.

If you change the size of draw and imported objects within the Animation view, the 
original image size of that object within the Draw view remains unchanged, and 
only the selected keyframe is affected. If you change the size of the object within 
the Draw view, that object is resized in all of the keyframes where that object 
appears.

To learn more about refer to

Original images “Understanding original images,” on page 2-28
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Figure 2-7. Animation view

Table 2-5. The Animation view main features

Feature Function

Workspace The area in which the selected keyframe can be edited using 
the commands and controls available in the Animation 
view. The size of the workspace is defined in the 
WebAnimator preferences (choose “Preferences” from the 
Edit menu).

Cursor Position Indicates the position of the cursor in the current keyframe.

Selected Keyframes Select Frames provides both an indicator of the range of 
keyframes currently selected and a means of selecting 
keyframes. The two numbers to the right of the Select 
Frames Button are the first and last keyframes of the 
currently selected range. If only one keyframe is selected, 
these numbers are identical.

Selected Keyframes

Show Off Screen button

Animation View 
Tool palette

Cursor Position Play

Workspace View Bar
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Animation view tool palette
The Animation view tool palette contains the tools and buttons you need to create 
or edit animated scenes. You may use the Animation view tool palette to move an 
object or change its size. WebAnimator automatically animates a foreground object 
if it is in a different position, or has a different size, in two adjacent keyframes. The 
object moves, grows or shrinks automatically during playback. Also, with the 
Animation view tool palette, you can play the scene, move through the keyframes, 
add new keyframes to the Storyboard, or display any of the three viewing plane.

The Animation view tool palette “floats” above the screen and may be moved to 
any location.

Show Off Screen button Displays all keyframes centered in the window and displays 
elements that are outside the keyframe boundary. These are 
objects that have been selected and moved off the visible 
portion of the keyframe, facilitating the ability to make 
objects slide in from off screen.

Play Plays the current scene from the selected keyframe. To stop 
the scene, press Cmd-period for Macintosh or Esc for 
Windows.

Tool palette Contain controls for playing the current scene, adjusting the 
layering of objects in the current scene, creating new 
objects, selecting, moving, and resizing objects, changing 
the background color, and recording sound, creating a 
transition, and adjusting the timing for the active keyframe. 
(see Figure 2-8)

View Bar Allows you to switch between the Template Studio, 
Animation, Storyboard, Draw, Cel, and Project views.

Table 2-5. The Animation view main features CONTINUED

Feature Function
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Figure 2-8. Animation view tool palette

Table 2-6. Animation view tool palette functions

Tool/Button Function

The Pointer tool operates the same as in the Storyboard view.

The Resize tool operates the same as in the Storyboard view.

The Play button operates the same as in the Storyboard view.

The Rewind button “rewinds” the scene to the first keyframe in the 
current scene. 

This function can also be performed by choosing “Goto Beginning” 
from the Play menu.

The Previous Frame button “rewinds” the scene to one frame earlier 
in the scene.

This function can also be performed by choosing “Previous 
Keyframe” from the Play menu.

The Keyframe Number display indicates the active keyframe in the 
Animation view.

Play
Keyframe 
Number Next Frame

Fast Forward

Frame Time

Previous Frame

Rewind

New Key Frame

Resize

Pointer

Background Color

Hidden Viewing PlaneForeground Viewing Plane

Record Sound

Background Viewing Plane

Time ControlsTransitions
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The Next Frame button “fast forwards” the scene to one keyframe 
later in the scene. 

This function can also be performed by choosing “Next Keyframe” 
from the Play menu. 

The Fast Forward button “fast forwards” the scene to the last 
keyframe in the current scene. 

This function can also be performed by choosing “Goto End” from 
the Play menu.

The New button operates the same as in the Storyboard view.

The Fore button operates the same as in the Storyboard view.

The Back button operates the same as in the Storyboard view.

The Hidden button operates the same as in the Storyboard view.

The Rec button displays a dialog allowing you to record sound in the 
sound segment for the selected keyframe.

The Trans button displays a dialog so you can apply a visual 
transition to the active keyframe. Transitions are effects similar to 
those often seen in video segments and made by effects generators 
(wipes, dissolves, sweeps, etc.). 

This function can also be performed by choosing “Transition...” 
from the Animation menu, or pressing Cmd/Ctrl-T.

The Background Color tool displays a dialog allowing you to 
changing the color of the background in the active keyframe. A 
background color may be a solid color or a blend of colors. The ten 
templates at the bottom of the dialog are the available background 
blends.

This function can also be performed by choosing “Background 
Color...” from the Animation menu, or pressing Cmd/Ctrl-B.

Table 2-6. Animation view tool palette functions CONTINUED

Tool/Button Function
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Working in the Draw view
The Animation view displays your scene keyframes in actual size and can be used 
to create and edit draw and text objects for your scene. This view contains 
commands and tools for creating and placing Draw and Text objects, applying 
color backgrounds, and creating Sprite objects.

Objects drawn in this view appear only in the keyframes selected in the Storyboard 
view before switching to the Draw view. If you draw an object and it appears only 
in one keyframe, it is because it’s automatically hidden in the rest.

Objects within the Draw view can be simple or complex. Complex objects are 
composed of multiple draw and text elements that move together as one object. A 
simple object contains only one element and moves independently of other objects. 
The New button in the Draw view tool pallets can be used to define simple and 
complex objects.

To learn more about refer to

Creating objects Chapter 5, “Creating, Editing, Animating, and Playing 
Scenes”

Simple and complex objects “Creating simple and complex objects,” on page 5-8

Draw view main features
When you are in the Draw view, all drawing work is done on the workspace. The 
objects can be arranged and layered in the workspace. All changes to the shape, 
color or size of object-elements made on the workspace are recorded in every 
keyframe of the scene, as these changes alter the original image of the objects 
involved. 

When an object is drawn in the Draw view, it exists in all keyframes—it is simply 
hidden in the keyframes in which it is not displayed.

The Time Control display indicates the time between this keyframe 
and the next keyframe. You may change the time in the keyframe by 
clicking on its time control and entering the desired time in minutes, 
seconds, and frames. 

This function can also be performed by choosing “Change Time...” 
from the Animation menu.

Table 2-6. Animation view tool palette functions CONTINUED

Tool/Button Function
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To open the Draw view, choose “Draw” from the View menu, press Cmd/Ctrl-D, or 
click the Draw button from the WebAnimator View Bar.

To learn more about refer to

Original images “Understanding original images,” on page 2-28

Figure 2-9. Draw view

Table 2-7. The Draw view main features

Feature Function

Workspace Displays the active keyframe indicated in the tool palette. 
This keyframe corresponds to the keyframe number in the 
Storyboard view.

Cursor Position Indicates the position of the cursor in the current keyframe.

Selected Keyframes Indicates the keyframe is selected. 

Selected Keyframes

Show Off Screen button

WorkspaceDraw View 
Tool Palette

View Bar

Cursor Position Play
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Understanding original images
When an object is imported or drawn in WebAnimator’s Draw view, it has an 
original image size. When the original image is displayed in the Animation view, it 
is called the playback image. When an object is sized or moved in the Animation 
view, the original image size is not altered. This gives total control of the object 
size to the Draw view.

Size and movement changes made within the Animation view affect the object’s 
appearance or playback image, and not its original image. No matter what changes 
are made to the object’s playback image in the Animation view, WebAnimator 
remembers the object’s original image size and shape in the Draw view. 

Changes made in the Animation view affect only the size or position of the 
playback image in those keyframes which are selected. Remember that animation 
size changes are based upon the original image size of the object. So, if an object is 
edited in the Draw view, and the original image size of the object is changed, the 
size of the object in the Animation view is also changed proportionally.

When you display objects in the Draw view that were resized in the Animation 
view, the selected objects temporarily return to their original image size. Objects 
which are not selected retain their animated or playback image. Changes to the size 
of an object are best made in the Draw view to maintain quality and reduce the 
“jaggies” to graphics.

Show Off Screen button Displays all keyframes centered in the window and 
displays elements that are outside the keyframe boundary. 
These are objects that have been selected and moved off the 
visible portion of the keyframe, facilitating the ability to 
make objects slide in from off screen.

Play Plays the current scene from the selected keyframe. To stop 
the scene, press Cmd-period for Macintosh or Esc for 
Windows.

Tool palette Contain controls for creating new simple and complex 
draw and text objects, selecting, moving, and resizing 
objects, applying color, creating Sprite object cels, and 
applying shadows.

View Bar Allows you to switch between the Template Studio, 
Animation, Storyboard, Draw, Cel, and Project views.

Table 2-7. The Draw view main features CONTINUED

Feature Function
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Draw view tool palette
The Draw view tool palette appears automatically whenever you switch to the 
Draw view and contains the tools and buttons you need to create or edit draw or text 
objects within the scene. You use the tools and buttons from the tool palette in 
much the same way you use traditional artist tools: you have to pick them up before 
you start to draw. You “pick up,” or select, a tool from Draw view tool palette by 
clicking on it before drawing in the document page. 

After using a tool, the cursor reverts back to the Pointer. The Draw tool palette 
“floats” above the screen and may be moved to any location. You can move the tool 
palette around the screen by clicking anywhere in the Title bar, holding down the 
mouse button, and dragging to a new location. 

Figure 2-10. Draw view tool palette

Table 2-8. Draw view tool palette functions

Tool Function

The New Object button ends editing of the selected object 
and begins editing of a new, independent object. This is 
how simple or complex objects are defined. 

The Text tool adds text to the active keyframe. 

The Pointer tool selects, moves, and resizes objects.

Rectangle

Cel Number

Shadow

Previous/Next Cel

Oval

Rounded Rectangle

New Object

Text Pointer

New Cel

Object Color

Freehand

Line

Remove Cel

Line-Width

Polygon
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Working in the Cel view
The Cel view is used to view and adjust the timing of the cels of an object. Cels are 
another way to create animations. In the Storyboard and Animation views, an 
object is animated by moving across the screen or changing its size. In cel 
animation, an object’s images change in a cyclic manner. A bird flapping its wings, 
a logo spinning, or a button flashing are examples of objects animated with cel 
animation.

Each object in WebAnimator is comprised of one or more cels. A cel is an image, 
either drawn in WebAnimator or imported from another program. Most objects 
have only one cel, so their image remains constant. However, if an object has more 

The Line tool creates straight lines.

The Rectangle tool creates rectangles and squares. 

The Freehand tool creates freeform shapes. 

The Rounded Rectangle tool creates rounded rectangles.

The Polygon tool creates polygons of any shape. 

The Oval tool creates circles and ovals. 

The Shadow tool displays a dialog so you can apply a 
shadow to any selected object(s). 

The Object Color palette consists of three color palettes 
which can be used to apply color to the fills, lines, and 
shadows of selected objects.

The Line-Width palette changes the line width of selected 
objects.

The New Cel button creates a new Sprite cel identical to 
the current cel. 

The Remove Cel button cuts the current cel from the 
active Sprite object.

The Previous and Next Cel buttons allows you to move 
between various cels of your Sprite object to view or edit 
objects.

Table 2-8. Draw view tool palette functions CONTINUED

Tool Function
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than one cel, then the object’s images change in a cyclic fashion, one cel or image 
after another. After the last cel is displayed, the cycle starts with the first cel and the 
cycle repeats. Because the images are displayed quickly on the screen, there is an 
illusion of motion, or animation.

In this view you can see each cel of an object and the order in which the cels are 
displayed. The time allotted for each cel is displayed underneath the cel’s frames. 
The default is 1 frame or 1/30 of a second. This time can be adjusted for each cel.

If an object has multiple cels, it can also be animated in the Storyboard or 
Animation views just like any other object. For example, a spinning logo can also 
move across the screen and grow in size as it spins.

Sprite objects can be created in the Draw view or imported in the Animation view. 
Like the adjustments that can be made to your keyframes in the Storyboard view, 
the Cel view has similar functions for the management of Sprite objects. Animated 
PICS objects can be imported as Sprite objects. 

To open the Cel view, choose “Object Cels” from the View menu, or click the Cel 
button from the WebAnimator View Bar.

To learn more about refer to

Creating Sprite objects “Creating Sprite objects,” on page 7-25
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Figure 2-11. Cel view

Working in the Project view
The Project view is used to combine multiple scenes to create one continuous 
production. Project files are not very large because they only reference and launch 
the original scene files as they are needed within the project sequence. Since all 
Web pages must be self-contained, it is not recommended that you use the project 
feature of WebAnimator when creating an animated graphic to be used in your Web 
site. You can however have multiple pages each with its own scene.

To open the Project view, choose “Project” from the View menu, or click the 
Project button from the WebAnimator View Bar.

The project window appears with the current scene added to the project. 
Information such as the scene file name, file size, and total run time is displayed in 
each Scene block.

Cel View BarSelected Cel
Elapsed 

Sprite Time
Elapsed 
Cel Time

Play
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The Project menu is used to add and remove scene files to the project. To play your 
project, click the Play button at the bottom of the window. The project plays from 
the beginning of the first scene. Press Cmd-. (Cmd-period) for Macintosh or Esc for 
Windows, to stop the project.

To learn more about refer to

Creating projects “Creating projects,” on page 7-33

Figure 2-12. Project view

Playing your scenes
You can play the current scene from any view in WebAnimator. You can play your 
scene from the beginning, start from a selected keyframe, or only play selected 
keyframes (Storyboard view only). To stop the playing of the scene before reaching 
the end, type Cmd-. (Cmd-period) for Macintosh or Esc for Windows. Script 
objects can only be played from the Cel view.

Selected Scene FileScene Files View Bar

Play

Empty Scene Block
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Using the Play button
There are Play buttons at the bottom of the Storyboard, Animation, Draw, Cel, and 
Project view windows. In the Storyboard, Animation, and Draw views, the Play 
button allows you to play the scene from the beginning. There are also Play buttons 
in the Animate and Storyboard view tool palettes. The Play button plays from the 
selected keyframe.

The Template Studio also contains a Play button for playing scenes in the created 
Template Studio Scene Preview.

In the Storyboard or Animation view, you select a range of keyframes and play 
only those keyframes. This is useful if you have a scene with a large number of 
keyframes and are only working on a small section of the scene.

Most of the commands in the Play menu can only be used in the Template Studio, 
Storyboard, and Animation views. The “Play” command in the Play menu 
however, can be used from any view to play the current scene, Sprite object, or 
project. 

Using other play controls
The Animation and Storyboard views have additional tools for playing and 
advancing keyframes. These controls work similar to the controls on a VCR and are 
located next to the Play button. 

Rewind displays the first keyframe in the scene. Fast Forward displays the last 
keyframe in the scene. Previous and Next Frame rewind or advance the scene one 
keyframe at a time. The Keyframe Number in the middle of the controls shows the 
number of the current keyframe.

The commands from the Play menu can also be used to navigate through your 
scene. 

Figure 2-13. Animation view play controls

Rewind
Keyframe 
Number

Next Frame

Fast Forward

Previous Frame
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To learn more about refer to

The Play menu “Play Menu,” on page A-22




